rails4.2 rails g model 時のエラー対策「Specified ‘mysql2’ for database adapter, but the gem is not loaded. Add `gem ‘mysql2’` to your Gemfile」

Pocket

rails g model するとき、に下記のエラーが出たときの対策。

Specified ‘mysql2’ for database adapter, but the gem is not loaded. Add gem 'mysql2' to your Gemfile

対策

vim Gemfile

バージョンしているするように書き換え。

gem 'mysql2'

↓

gem 'mysql2', '~> 0.3.20'

アップデート

$ bundle update

環境

ruby 2.2.3
Rails 4.2.4
MySQL 5.6.x

参照

Rails mysql2でrake db:createがエラー問題

SNSでもご購読できます。

スポンサードリンク

カテゴリー

アーカイブ