Ruby

Pocket

CentOS6.5 : Ruby2.0のインストール。rbenvとruby-buildを使って複数バージョンを切り替えて使う環境を構築する。

Pocket

gitをインストールしていない場合は、インストールする。

複数バージョンのrubyをインストールしておき、切り替えるために必要なrbenv をインストールする。

Rubyをインストールには、ruby-build を使用する。ruby ver.2系をインスト-ルする。

情報を更新

利用するRubyのバージョンを設定。

rbenvを使ってインストールされているRubyの一覧を表示

設定したRubyのバージョンが有効になっているか確認

参照:
sstephenson / rbenv
sstephenson / ruby-build

rbenvとruby-build : rbenv install 2.0.0-p247でRubyのインストールが失敗する。CentOS6.5。

Pocket

rbenvとruby-build を使って、Ruby 2.0.0-p247をCentOS6.5にインストールしようとすると、

下記のエラーメッセージがでて、2.0.0-p247のインストールに失敗します。

これは、rbenvのバグではなく、Rubyのバグのようです。
https://github.com/sstephenson/ruby-build/issues/444

すでに、修正が完了しています。
http://bugs.ruby-lang.org/issues/9065

よって、執筆時点で最新の安定版であるruby 2.0.0-p353をインストールすることで解決しました。